Bug 9948 - Time Format Error in some locales
Summary: Time Format Error in some locales
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: mscorlib ()
Version: master
Hardware: PC All
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-01-31 12:13 UTC by qq
Modified: 2013-02-08 15:17 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description qq 2013-01-31 12:13:38 UTC
$ csharp 
        csharp> using System.Globalization; 
        csharp> foreach (var c in CultureInfo.GetCultures(CultureTypes.AllCultures).Where(a => !a.IsNeutralCulture).Where(a=>a.Name.StartsWith("z"))) Console.WriteLine ("{0}: {1}", c.Name, DateTime.Now.ToString (c)); 
        zh-TW: 2013/1/31 上11時08分29秒 
        zh-CN: 13-1-31 上11时08分29秒 
        zh-HK: 13年1月31日 上11時08分29秒 
        zh-SG: 31/01/13 上 11:08:29 
        zh-MO: 13年1月31日 上11時08分29秒 

The character "上" should be "上午" which represents "AM" in Chinese.
Comment 1 Marek Safar 2013-02-08 12:38:50 UTC
I cannot reproduce it with master.

I am getting something like "下午". Are you really running master?
Comment 2 Jonathan Pryor 2013-02-08 15:17:42 UTC
Hm, I must have been using 2.10 when I ran that, not master. Oops.

Looks like this has already been fixed in Mono 3.0.x then.