Bug 9940 - VS2010 Crashing a lot lately v4.4.54
Summary: VS2010 Crashing a lot lately v4.4.54
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 3.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Dominique Louis
URL:
Depends on:
Blocks:
 
Reported: 2013-01-31 08:59 UTC by sharkbugzilla
Modified: 2015-06-22 16:47 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description sharkbugzilla 2013-01-31 08:59:45 UTC
It seems lately I’m getting more VS2010 crashes with the message “Microsoft Visual Studio has encountered a problem and needs to close”. The “minidump” file Microsoft wants sent says:

Exception Code 0xc0000005 – The thread tried to read from or write to a virtual address for which it does not have the appropriate access.

It seems to happen more frequently when I have a device attached, regardless of debugging or running a release version of an app.

Since this is a new occurrence of this issue (and I’ve been running MFA v4.4.54 for a while now), it occurs to me it may be related to my recent upgrade of my Samsung Galaxy Tab 2 7” from OS version 1.0.4 to 4.1.1. Have I been Jelly-Bean’d?

Jonathan Pryor asked me to file this report...
Comment 1 Miguel de Icaza [MSFT] 2015-06-22 16:47:01 UTC
This code has changed enough that we can close this.