Bug 9835 - Space in XmlSchema attribute causes validation to fail.
Summary: Space in XmlSchema attribute causes validation to fail.
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System.XML ()
Version: master
Hardware: PC Linux
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-01-29 04:09 UTC by Alistair Leslie-Hughes
Modified: 2013-01-31 03:35 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Alistair Leslie-Hughes 2013-01-29 04:09:26 UTC
Install WINE
Install mono if it didn't get installed. (some distro install wine-mono by default)

copy "C:\Windows\Microsoft.NET\Framework\v2.0.50727\CONFIG\security.config" from a windows machine to the wine equivalent directory.

Download SQLManagementStudio_x86_ENU.exe from http://www.microsoft.com/en-us/download/details.aspx?id=7593


run "WINE_MONO_TRACE=all wine SQLManagementStudio_x86_ENU.exe >& log.txt" 

note: this log file ends up > 1G.

In the log file you will find the following.

[00000036: 155.18366 43] LEAVE: System.Exception:get_Message ()[STRING:0223DBE0:XmlSchema error: required  is not a valid value for use attribute]
[00000036: 155.18368 42] LEAVE: System.Xml.Schema.XmlSchemaException:get_Message ()[STRING:0223DBE0:XmlSchema error: required  is not a valid value for use attribute]

If you have look, there is an extra space after required (if quotes where there it would make it easier to spot).

I modified file XmlSchemaUtil.cs to .TrimEnd() the reader.Value (for "use"), and the error goes way.  This isn't a proper fix though.
Comment 1 Alistair Leslie-Hughes 2013-01-29 04:12:22 UTC
Wine bug reference http://bugs.winehq.org/show_bug.cgi?id=31154
Comment 2 Atsushi Eno 2013-01-29 10:26:56 UTC
I'm not going to actually do this very indirect steps to reproduce which is almost impossible to verify. Instead I made a most-probable fix in master.
Comment 3 Alistair Leslie-Hughes 2013-01-31 03:35:00 UTC
Thanks