Bug 9793 - Noticeable Visual Studio Slowness in Mono for Android 4.4x
Summary: Noticeable Visual Studio Slowness in Mono for Android 4.4x
Status: CLOSED NORESPONSE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 3.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-01-25 10:13 UTC by Allie Miller
Modified: 2015-08-24 17:01 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED NORESPONSE

Description Allie Miller 2013-01-25 10:13:35 UTC
Seen in this forum discussion: http://forums.xamarin.com/discussion/558/vs-2012-slows-down-or-even-freezes-after-debugging-session-or-after-running-without-debug#latest

After installing Mono for Android 4.4.50, results in  slowness and freezing after debug session or run without debugging.

System informations:
- WinXP Professional (32Bit) SP 3
- Intel Core i3 / 2GB RAM
- VS2010 SP1, but occurs in VS2012 as well

The slowness makes itself noticeable by:
- very slow build (> 30 sec.) after 3-4 debug sessions
- can't debug after the 3.-4. debug session
- when pressing a key on the keyboard the pressed key appears after 2-3sec. on the monitor (after the 5-6 debug session)
- then th VS needs more than 600MB memory - when I'm doing nothing (at times also more than 800MB)
Comment 3 Timothy 2013-02-26 08:27:10 UTC
I'm having similar issues (Mono for Android 4.6)
VS freezes when starting to debug, when stopping to debug
when trying to edit AXML files, when switching between source files.

Only when working on Mono for Android projects. Freezes can take up to a few minutes, sometimes I'm forced to kill Visual Studio.

CPU usage raises to 20% for child process of Visual Studio


System information:

 - Windows 7 Ultimate
 - Intel Xeon Dual Quad Core CPU / 12GB RAM
 - VS2012
Comment 4 Timothy 2013-02-27 00:14:20 UTC
If you kill adb.exe Visual Studio resumes... of course that means your debug session is disconnected as well.
Comment 5 Rajneesh Kumar 2015-07-21 13:35:05 UTC
Could you please check this issue with the latest stable build XVS 3.11.666 and please check its working for you OR you are till getting same behaviour ?

Thanks..!
Comment 6 Rajneesh Kumar 2015-08-04 13:07:26 UTC
There is no response from the reporter. So as of now I am closing this issue against stable build XVS 3.11.666. Please feel free to reopen this issue if you again facing this behavior at your end.

Hence Closing this issue.

Thanks..!
Comment 7 Enzo Heredia 2015-08-11 12:45:03 UTC
not reproducible in xma 4.0.0.837