Bug 978 - Can't close solution
Summary: Can't close solution
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 2.6
Hardware: PC Windows
: --- trivial
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-09-21 20:37 UTC by yeme9b
Modified: 2011-09-28 19:10 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description yeme9b 2011-09-21 20:37:29 UTC
When closing solution halts a message, and it seems to close it but at least the name remains in the title.

Could not close solution 'Mono hola mundo'.
Details
GLib.GException: Failed to open file 'C:\Program Files\Programación\MonoDevelop\AddIns\WelcomePage\md-logo.png': No such file or directory

   en Gdk.Pixbuf..ctor(String filename)

   en MonoDevelop.WelcomePage.WelcomePageWidget..ctor(WelcomePageView parentView)

   en MonoDevelop.WelcomePage.WelcomePageView.Build()

   en MonoDevelop.WelcomePage.WelcomePageView..ctor()

   en MonoDevelop.WelcomePage.ShowWelcomePageHandler.Show()

   en MonoDevelop.WelcomePage.ShowWelcomePageOnStartUpHandler.<Run>b__1(Object , EventArgs )

   en System.EventHandler.Invoke(Object sender, EventArgs e)

   en MonoDevelop.Ide.RootWorkspace.NotifyItemRemovedGui(WorkspaceItem item)

   en MonoDevelop.Ide.RootWorkspace.NotifyItemRemoved(WorkspaceItem item)

   en MonoDevelop.Ide.RootWorkspaceItemCollection.RemoveItem(Int32 index)

   en System.Collections.ObjectModel.Collection`1.Remove(T item)

   en MonoDevelop.Ide.RootWorkspace.Close(Boolean saveWorkspacePreferencies, Boolean closeProjectFiles)
Comment 1 Alan McGovern 2011-09-28 12:01:09 UTC
This should be fixed in MonoDevelop 2.8 beta 3 as the code to load logos has changed significantly. Can you try this release and see if the issue has been resolved? If the issue is there, it's probably because you have special characters in the path to MonoDevelop. Can you confirm what the actual full path to monodevelop is? The directory name appears to be corrupt in bugzilla.
Comment 2 yeme9b 2011-09-28 19:06:19 UTC
Seems that works fine with 2.8 beta 3.
Comment 3 Alan McGovern 2011-09-28 19:10:35 UTC
In that case I'll close the bug. Thanks for the report.