Bug 9631 - When user is not activated and clicks configure on the Tools->Options->Xamarin->iOS Settings page, they should get the UPGRADE workflow
Summary: When user is not activated and clicks configure on the Tools->Options->Xamari...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.0.x
Hardware: PC Windows
: Normal enhancement
Target Milestone: 1.3.x
Assignee: Dominique Louis
URL:
: 9697 ()
Depends on:
Blocks:
 
Reported: 2013-01-16 20:54 UTC by PJ
Modified: 2013-05-30 06:31 UTC (History)
6 users (show)

Tags: error improvement
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description PJ 2013-01-16 20:54:59 UTC
Steps to reproduce:

1) Don't have a license file or account
2) Open VS without opening a project
3) Go to Tools->Options->Xamarin->iOS
4) Click [Configure]

Actual behavior:
http://screencast.com/t/OgKtnfeC2
"Please activate your Xamarin.iOS before configure your build host"

Expected behavior:

A) (best) User should just be prompted to activate

B) (easiest) Text should be updated to read

"Please activate Xamarin.iOS before configuring your build host."

MTVS 1.0.681

At the very very least, let's implement B) and move the A) solution to V2
Comment 2 Vinicius Jarina 2013-01-29 14:08:37 UTC
*** Bug 9697 has been marked as a duplicate of this bug. ***
Comment 3 Dominique Louis 2013-05-07 15:48:09 UTC
Should be fixed as part of this commit to master :
https://github.com/xamarin/XamarinVS/commit/b7a17b61238b0d1e8bab52671abd5ef30c6e2536
Comment 4 Peter Collins 2013-05-13 15:02:40 UTC
Fix verified in Xamarin.iOS 1.2.22 (6182aa0a)
Comment 5 Mohit Kheterpal 2013-05-30 06:31:44 UTC
Today we have checked this issue on following builds:

VS 2012 /2010
MTVS 1.2.103
MT 6.2.6.6
Mono 2.10.12

When we click on configure in Xamarin->iOS setting then it prompts us to activate Trial or purchase license or log-in with xamarin account.