Bug 9528 - MonoDevelop cannot stops build and build doesn't stops.
Summary: MonoDevelop cannot stops build and build doesn't stops.
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Android Add-in ()
Version: 3.0.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Alan McGovern
URL:
Depends on:
Blocks:
 
Reported: 2013-01-14 03:13 UTC by cheansiong
Modified: 2013-03-18 10:31 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description cheansiong 2013-01-14 03:13:57 UTC
Create a few android xamarin projects. 1 application project and 2 library projects.
Application has reference to both library project (a) and (b).
Library project (a) has reference to library project (b).

Some times, building the solution will caused the application cannot continue.

Version information:
MonoDevelop 3.0.6

Installation UUID: edf4511c-49f0-401b-ab01-005c2a63461c

Runtime:

	Microsoft .NET 4.0.30319.296

	GTK 2.16.6

	GTK# (2.12.0.0)

Mono for Android: 4.4.54

Android SDK: (Removed intentionally)

	Supported Android versions:

		2.1   (API level 7)

		2.2   (API level 8)

		2.3   (API level 10)

		3.1   (API level 12)

		3.2   (API level 13)

		4.0   (API level 14)

		4.0.3 (API level 15)

		4.1   (API level 16)

		4.2   (API level 17)

Java SDK: C:\Program Files (x86)\Java\jdk1.6.0_31

No build info

Operating System:

	Windows 6.1.7601.65536 (64-bit)
Comment 1 cheansiong 2013-01-20 22:59:19 UTC
Any updates?
Comment 3 Alan McGovern 2013-01-22 05:32:20 UTC
I just want to confirm. The issue you're having is that if you open the solution in the demo zip file, MonoDevelop will hang sometimes while building the project? Is this hang temporary or does monodevelop crash completely and needs to be restarted?
Comment 4 cheansiong 2013-01-22 07:30:50 UTC
The mono develop will be shown as building however the status at the status bar shows 'Ready'. And the progressbar on the status bar doesn't progress.

When this happens, mono develop can't be stop from building and I were force to close the application. When trying to atop the application, the mono develop hangs and do not response.

Hopes this clarified.
Comment 5 cheansiong 2013-02-03 20:28:15 UTC
Hi, would you update the status a little bit? 
Thanks.
Comment 6 Alan McGovern 2013-02-04 05:46:12 UTC
Sorry for the delay in responding. I actually spent some times on this bug and could not reproduce the problem. I suspect that it has been fixed since MonoDevelop 3.0.6 was released so the best advice I can give is to wait for the next stable release to come out and test again then. I'd be reasonably confident that the issue will be gone then. I'd expect the next stable to be released within a week from today.

I am going to leave this bug open until we can get confirmation from you that the bug is definitely gone.
Comment 7 cheansiong 2013-02-04 21:43:11 UTC
I'm sorry to inform you that the problem still exist while I'm using version 3.0.6  since yesterday.
Comment 8 Mikayla Hutchinson [MSFT] 2013-02-05 21:48:14 UTC
Alan said that it has been fixed *since* 3.0.6, so you will have to wait until the next version is released.
Comment 9 cheansiong 2013-03-18 05:27:38 UTC
What can I do if the bugs still exists since I am using version 3.0.6 now.
Comment 10 Mikayla Hutchinson [MSFT] 2013-03-18 10:31:02 UTC
As I said before, it was fixed SINCE 3.0.6, not IN 3.0.6. You need a version NEWER than 3.0.6.

Please upgrade to Xamarin Studio 4.0.2.