Bug 9424 - Very Odd Autoformatting
Summary: Very Odd Autoformatting
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: C# Binding ()
Version: 2.8.2
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2013-01-09 11:08 UTC by Draco18s
Modified: 2013-01-09 12:11 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Before and after a newline (7.66 KB, image/png)
2013-01-09 11:08 UTC, Draco18s
Details
Before and after block-close (7.63 KB, image/png)
2013-01-09 11:17 UTC, Draco18s
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Draco18s 2013-01-09 11:08:52 UTC
Created attachment 3183 [details]
Before and after a newline

I went to type a new code block, and when I hit Enter, the code was auto-formatted in a very bizarre fashion.

See the attached screenshot.

The top half is a screenshot before I hit [ENTER] for a newline, the bottom half is the result, post auto-format.  The result not only doesn't make any logical sense, it [i]is not valid code[/i], [b]AND[/b] my cursor is not in an expected location.
Comment 1 Draco18s 2013-01-09 11:17:23 UTC
Created attachment 3184 [details]
Before and after block-close

And here's what happened when I tried to add a new if() block.  As soon as I hit } it did crazy weird shit.

I can't work like this.  I can tolerate the oddities of the program when working in Javascript (the program not code hinting well, and duplicating characters when pasting strings), but working in C# is impossible if it's going to keep autocorrecting my code to garbage.
Comment 2 Mike Krüger 2013-01-09 12:04:21 UTC
Should be fixed in the 3.x versions - 2.8.2 is working with a >3 year old engine
:(
Comment 3 Draco18s 2013-01-09 12:11:36 UTC
Thanks Mike.
I'll go look for a newer version of MD.  Unity installed this one and apparently doesn't update what they include very often.