Bug 9336 - Does not follow Link for AndroidManifest.xml
Summary: Does not follow Link for AndroidManifest.xml
Status: RESOLVED INVALID
Alias: None
Product: Android
Classification: Xamarin
Component: Designer ()
Version: 4.4.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2013-01-07 15:11 UTC by TotallyEvil Devs
Modified: 2013-03-13 05:41 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description TotallyEvil Devs 2013-01-07 15:11:18 UTC
<ItemGroup>
    <Content Include="..\Android\Properties\AndroidManifest.xml">
	  <Link>Properties\AndroidManifest.xml</Link>
	</Content>
  </ItemGroup>

This does not work in 4.4.54. Solution explorer shows the file correctly, but designer does not know to read it from the link.
Comment 1 Mikayla Hutchinson [MSFT] 2013-01-09 11:19:06 UTC
In general, "Link" metadata within MSBuild files are not used for anything other than the solution tree. Everything else uses the "real" paths.

The designer should be reading the file specified in the AndroidManifest property, so you would need:

  <PropertyGroup>
    <... other elements ...>
    <AndroidManifest>..\Android\Properties\AndroidManifest.xml</AndroidManifest>
  </PropertyGroup>
Comment 2 Lluis Sanchez 2013-03-13 05:41:07 UTC
As Michael said, you need to specify the correct path in an <AndroidManifest> element. Closing.