Bug 9205 - MTVS: " MS Visual Studio is loading the projects" pop up while trying to open an already existing iOS project in VS 2010
Summary: MTVS: " MS Visual Studio is loading the projects" pop up while trying to open...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 0.x Insider Preview
Hardware: PC Mac OS
: Normal normal
Target Milestone: 1.3.x
Assignee: Vinicius Jarina
URL:
Depends on:
Blocks:
 
Reported: 2013-01-02 16:44 UTC by GouriKumari
Modified: 2013-04-12 13:35 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 Vinicius Jarina 2013-01-02 22:33:43 UTC
Hello Gouri

I am opening several already existent projects here, we need more indo what exactly is happening.
Comment 2 Marek Habersack 2013-01-03 03:22:02 UTC
It doesn't look like a bug in MTVS
Comment 3 PJ 2013-01-03 19:44:41 UTC
This does not happen with any other project... let me know if you cannot reproduce but this definitely needs to go. Even if it's a VS dialog, it probably appears because of something we're doing.


Many customers will report this day 1.
Comment 4 Marek Habersack 2013-01-04 03:43:28 UTC
None of us are able to repro it. Can you attach the project that Gouri was opening? Is it reproducible with vs2012? Does it happen on other versions of Windows, or just W8?
Comment 6 PJ 2013-01-04 15:04:00 UTC
Raising severity as this does happen for all of us in QA fairly regularly. We'll have to mention this as a known issue for the Customer beta.
Comment 8 narayanp 2013-01-25 07:25:43 UTC
We are able to reproduce this issue on Windows 8, VS 2010.  On opening any existing iOS project a popup appears.

Supplement info:
http://www.screencast.com/t/bYdu0moD2h

However, with Window8(VS 2012) and Windows 7(VS 2010/12), On opening any existing iOS project no popup appears and project opened successfully. 

Environment:
mtvs-1.0.766.0
VS2010/12
Comment 9 Peter Collins 2013-01-25 15:35:51 UTC
Still seeing this issue consistently in VS2010 on a windows 8x64 physical machine [0]. Perhaps someone can use google remote desktop to attempt to use this machine to debug? I'm not sure of another way to provide any useful information to get to the bottom of this.

[0] http://screencast.com/t/rdl5v5BR

Env Details:
Win 8x64 physical machine
VS2010
X.iOS 1.1.0 (31754a9c)
Comment 10 PJ 2013-02-12 16:39:59 UTC
Dominique/Grendel any guidance on how to get a better trace here? Can we just try to attach one VS instance to another, repro and try to pause while it's showing this dialog?
Comment 11 Marek Habersack 2013-02-13 03:32:18 UTC
PJ, honestly, I have no idea what's going on here. You can attach another instance of VS and try to get a stack trace at this point, but not sure if it's gonna help much.
Comment 12 Saurabh 2013-04-12 13:35:47 UTC
Today we have checked this using following builds:

VS 2010/2012
Xamarin.Android 4.7.04001
MTVS 1.1.200

We are not seeing this dialog popup when open existing project on VS2010 and VS 2012. This is the screencast for the same: http://screencast.com/t/QnhDFaO7EFKM

Hence, closing this issue