Bug 9136 - Cannot read customize configuration section from app.config file
Summary: Cannot read customize configuration section from app.config file
Status: NEW
Alias: None
Product: Class Libraries
Classification: Mono
Component: System.Configuration ()
Version: master
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-12-27 03:05 UTC by Kevin.Kline
Modified: 2012-12-27 03:16 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Source Code. (90.44 KB, application/octet-stream)
2012-12-27 03:06 UTC, Kevin.Kline
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 9136 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description Kevin.Kline 2012-12-27 03:05:01 UTC
Hi all,

    I met this issue in many months ago. At newest version of Mono, this issue still at here.
I had a customize configuration section in "app.config" which it is will be used in our system. It's called "CustomerConfig".
I always get a EXCEPTION object when i use those methods at below:

  XmlDocument document = new XmlDocument();
  Configuration config = ConfigurationManager.OpenExeConfiguration(ConfigurationUserLevel.None);
  var object1 = config.GetSection("CustomerConfig");
  //EXCEPTION!!!
  //System.ArgumentNullException has been thrown
  //Argument cannot be null.
  //Parameter name: s
  document.LoadXml(object1.SectionInformation.GetRawXml());

   But, in the .NETFRAMEWORK 4.0, it's fine.
   Solution files already attached, pls check it.



System & Mono Enviroment Infomation:
-------------------------------------------------
Mono JIT compiler version 3.0.2 (master/9e7f206)
Copyright (C) 2002-2012 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
        TLS:           normal
        SIGSEGV:       normal
        Notification:  Thread + polling
        Architecture:  x86
        Disabled:      none
        Misc:          softdebug
        LLVM:          supported, not enabled.
        GC:            Included Boehm (with typed GC and Parallel Mark)

Windows 8(x64)


Thx,
Kevin
Comment 1 Kevin.Kline 2012-12-27 03:06:31 UTC
Created attachment 3134 [details]
Source Code.