Bug 9135 - MonoDevelop.Debugger: enable clipboard on disassembly
Summary: MonoDevelop.Debugger: enable clipboard on disassembly
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: Trunk
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2012-12-27 02:47 UTC by Atsushi Eno
Modified: 2013-01-02 16:02 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
patch (2.02 KB, patch)
2012-12-27 02:47 UTC, Atsushi Eno
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Atsushi Eno 2012-12-27 02:47:21 UTC
Created attachment 3133 [details]
patch

I had trouble on debugging dynamically generated IL on MonoDevelop mostly because it does not allow me to copy disassembly buffer, so I added Clipboard support.

(Maybe I also want "search" feature in the disassembly buffer, but that'd become another patch if I did.)
Comment 1 Jeffrey Stedfast 2013-01-02 16:02:25 UTC
committed to git master