Bug 8944 - If the updater service is down, switching channels throws an exception
Summary: If the updater service is down, switching channels throws an exception
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Updater ()
Version: 3.0.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-12-14 15:09 UTC by PJ
Modified: 2015-08-20 03:41 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description PJ 2012-12-14 15:09:44 UTC
Today the updater service was not responding for a little bit.

Under this condition, switching channels the the updater causes an exception:

Steps to reproduce
1) Check for Updates (sits at 'Checking for Updates')
2) Switch the channel selector to a different channel
3) Click switch channel

Expected behavior:
If the updater service is not available or the current checking for updates hasn't returned yet, just abort that and re-try with the new channel. The user should not see an exception.

Actual behavior:
Exception pop up appears
Mono 2.10.10: https://gist.github.com/58fe0a6270c40780cc45
Mono 2.10.9_10: https://gist.github.com/3074c078d41341c08e99

Appears on MD 3.0.5 Stable (tested only on mac during the outage)
Comment 1 Mikayla Hutchinson [MSFT] 2012-12-14 15:16:50 UTC
This was fixed in ui-refresh in https://github.com/xamarin/md-addins/commit/c89fdd0e1ee3ed6d11405c387b2ad934bfba7111

Not sure whether it's worth backporting.