Bug 8935 - keepass2 systray icon not working in GNOME notification area, 64 bit
Summary: keepass2 systray icon not working in GNOME notification area, 64 bit
Status: NEW
Alias: None
Product: Class Libraries
Classification: Mono
Component: Windows.Forms ()
Version: unspecified
Hardware: PC Linux
: Lowest normal
Target Milestone: Community
Assignee: Bugzilla
URL: http://sourceforge.net/p/keepass/bugs...
Depends on:
Blocks:
 
Reported: 2012-12-14 06:25 UTC by Johannes Rohr
Modified: 2017-09-01 11:56 UTC (History)
6 users (show)

Tags: mono-community
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 8935 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description Johannes Rohr 2012-12-14 06:25:50 UTC
I am not sure whether I have chosen the correct component. Keepass2 is a popular password keeping software. It is written in C#, originally for .NET, but it is also supported on mono down. However it does not use Gtk#. On Windows it can be minimized to the Systray, on Linux this also works on KDE platforms and on 32 bit GNOME platforms. However the systray/notification area icon fails to show up on GNOME on 64 bit systems. I have reported this issue to the keepass developers, but they concluded that this must be a mono bug and therefore should be reported here.

http://sourceforge.net/p/keepass/bugs/1051/

I can provide more details on request. However, as a layman, I would need some guidance on how to extract the necessary debug information if required.
Comment 1 Zoltan Varga 2012-12-16 15:42:28 UTC
-> winforms.
Comment 2 Johannes Rohr 2015-09-30 06:09:43 UTC
Hi, it's been three years and this doesn't seem to have been fixed. Now, the KDE plasma desktop is also affected (whereas it used to work in KDE 4.x)
Comment 3 Patrick Hofmann 2015-10-10 08:29:50 UTC
I am experiencing the same issues on gnome 3.16 and 3.18.
The tray icon is working, but shows as a black square.
Is there any chance there will be a fix?
Comment 4 Stephen Parry 2015-12-31 03:24:59 UTC
I can confirm that this is now affecting KDE - possibly since 4.1.2 of xamarin mono. It was working fine on KDE until very recently.
Comment 5 Timotheus Pokorra 2016-06-27 07:23:08 UTC
see a possible fix in this duplicate report: https://bugzilla.xamarin.com/show_bug.cgi?id=14976