Bug 8863 - Two XamMac assembly present in Edit references window and user is not able to add XamMac(0.9.48) assembly by checking it.
Summary: Two XamMac assembly present in Edit references window and user is not able to...
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Mac Add-in ()
Version: 4.0.8
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Aaron Bockover [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2012-12-10 04:09 UTC by narayanp
Modified: 2013-06-04 11:53 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description narayanp 2012-12-10 04:09:14 UTC
Step to reproduce:
1. Open XamMac sample application in MD e.g. AnimatedClock 
2. Right click on References folder of the sample and select Edit References option
3. Observe that Edit References window opens and there are two XamMac assemblies (XamMac 0.9.48 and XamMac 0.0.0) present in assemblies list
4. Check the checkbox of the XamMac 0.9.48 assembly
5. Observe that XamMac 0.0.0 assembly is checked automatically
6. Click on OK button and observe that Edit References window disappear
7. Again open Edit References window
8. Observe that the checkbox of XamMac 0.9.48 is unchecked and only XamMac 0.0.0 is checked

Actual result:
1. In Edit References window two XamMac assemblies (XamMac 0.9.48 and XamMac 0.0.0) present in assemblies list.
2. On Checking the checkbox of the XamMac 0.9.48 assembly, the checkbox of XamMac 0.0.0 assembly is checked automatically
3. After adding both XamMac assemblies (XamMac 0.9.48 and XamMac 0.0.0), when again open Edit References of the sample we observe that the checkbox of XamMac 0.9.48 appears unchecked and only XamMac 0.0.0 is checked.  

Expected result:
In Edit References window one  XamMac assemblies should displayed and user should able to add XamMac assembly successfully.

Screencast: 
http://www.screencast.com/t/84KetetgAYn

Environment:
All Mac
MonoFramework 2.10.9
MD 3.1.0 -d62ddbf6dfdb162fb7fcaf74bc3fe2e4d49dd1ca
xamarin.mac-0.9.48
Comment 2 Nischal 2012-12-11 09:53:35 UTC
Today we have verified this issue with following builds:

MonoDevelop 3.1.0 -0396b2d2f2392ce8d569a43045a01ba4263f8212
Xamarin.Mac 0.9.48 - f9ecbbdf58f5b098d39280d6432fb1d52bcc44a3
Mono 2.10.9

And this is working fine. Now we are not seeing Xamarin.Mac twice in edit reference and user able to select it.
Comment 3 Nischal 2013-02-25 03:40:04 UTC
Today we have verified this issue with following builds:

Xamarin.Mac 1.2.8
MD 4.0 - 7e31a9b052b9452b65268a357b4c0b83a848a6f8
Mono 2.10.11

And now this issue does not exist. As we are not seeing Xamarin.Mac twice in edit
reference.