Bug 8781 - Publish Android Application not creating an APK
Summary: Publish Android Application not creating an APK
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2012-12-05 14:20 UTC by Tom Opgenorth
Modified: 2016-08-03 15:24 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Tom Opgenorth 2012-12-05 14:20:57 UTC
The Publish Android Application command in the Tools menu of Visual Studio is not generating any output, i.e. there is no signed APK. There is a command console window that very briefly pops shortly after i run the command, but it is too quick for me to read or capture.

This is happening in Mono For Android 4.2.7 in both VS2010 and VS2012. Here is a video of the problem: http://screencast.com/t/jbbB7SU7J
Comment 2 dean.ellis 2012-12-06 06:09:06 UTC
I can replicate the bug, and have tested under monodevelop and it works in that IDE. Will now look into the VS AddIn to see what the issue is.
Comment 4 dean.ellis 2012-12-14 09:30:35 UTC
Fixed in monodroid-4.4-series/9d11b6d7af

The fix updates the publish code to Canonicalize the assembly
name by default then to lookup the Package name from the AndroidManifest.xml
if it exists. It will then use that to find the correct .apk to pubish