Bug 8759 - [xammac] Application does not run on debug or release when code signing is enabled
Summary: [xammac] Application does not run on debug or release when code signing is en...
Status: VERIFIED INVALID
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Mac Add-in ()
Version: 4.0.8
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Aaron Bockover [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2012-12-04 18:11 UTC by Peter Collins
Modified: 2013-06-04 11:53 UTC (History)
2 users (show)

Tags: xamarin mac; xammac
Is this bug a regression?: ---
Last known good build:


Attachments
sample Xam Mac project (6.35 MB, application/zip)
2012-12-04 18:11 UTC, Peter Collins
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED INVALID

Description Peter Collins 2012-12-04 18:11:52 UTC
Created attachment 3055 [details]
sample Xam Mac project

Setting code signing in a Xam.Mac project prevents the project from running in MD on either debug or release mode. Unfortunately, MD logs don't provide any useful information and there is no visible error displayed when the project does not run.

Steps to Reproduce:
1) Open A Xam Mac project in MD (I have attached a Xam Mac project).
2) Double click the project, enable code signing for debug and release configurations.
3) Attempt to run the solution with the debugger, without the debugger, and in release mode.
4) Application output pad pops up but the application fails to run.

Environment Details:
xam mac - 0.9.21
MD 3.1.0 - Build information:
Release ID: 30100000
Git revision: 044fb884195fb864d0d76a75486f84219a3b3a0e
Build date: 2012-12-04 19:55:45+0000
Xamarin addins: bb5d159c2a9933fe17e80f06dae7a58e0d35f1b7
Runtime:
Mono 2.10.11 (mono-2-10/6cee717)
GTK 2.24.13
GTK# (2.12.0.0)
Package version: 210100000
Comment 1 Peter Collins 2013-01-23 17:58:52 UTC
Currently unable to reproduce, and no update provided in over a month. Flagging as resolved invalid.
Comment 2 Nischal 2013-03-01 09:50:33 UTC
Today we have checked this issue with following builds:

X.S 4.0 - 1c3e943ebec6a7d6e695af9f7a1808ac5bafdb21
Xamarin.mac 1.2.25
Mono - 2.10.11 (mono-2-10/2baeee2)

And we observed that we can not check/uncheck Code signing option under project option for debug/release mode. So we are not able to reproduce this issue in case of debug mode. however in case of release mode after adding correct provisioning profile we can run the application successfully.

Changing the status to Verified.