Bug 8756 - [xammac] Advanced tab of info.plist throwing multiple NREs when attempting to add new Document Types
Summary: [xammac] Advanced tab of info.plist throwing multiple NREs when attempting to...
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Mac Add-in ()
Version: 4.0.8
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Aaron Bockover [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2012-12-04 17:28 UTC by Peter Collins
Modified: 2013-06-04 11:53 UTC (History)
3 users (show)

Tags: xamarin mac; xammac
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Peter Collins 2012-12-04 17:28:57 UTC
http://screencast.com/t/JvGJYjSCj5r

Steps to reproduce:
1) Open the info.plist file in any Xam.Mac project, go to the advanced tab.
2) Click the 'Add Document Type' button.
3) Attempt to add an image or fill out fields > NRE thrown.

NRE Stacktrace:
https://gist.github.com/fcf824f7db620945df22

IDE Log:
https://gist.github.com/ad429f63ef013b9c8b79

Environment Details:
xam mac - 0.9.21
MD 3.1.0 - Build information:
Release ID: 30100000
Git revision: 044fb884195fb864d0d76a75486f84219a3b3a0e
Build date: 2012-12-04 19:55:45+0000
Xamarin addins: bb5d159c2a9933fe17e80f06dae7a58e0d35f1b7
Runtime:
Mono 2.10.11 (mono-2-10/6cee717)
GTK 2.24.13
GTK# (2.12.0.0)
Package version: 210100000
Comment 1 Aaron Bockover [MSFT] 2012-12-06 21:47:52 UTC
This should be fixed.
Comment 2 Saurabh 2012-12-07 03:47:55 UTC
We have verified this issue with following builds:

Xamarin.Mac 0.9.30 - 5f9eab8f9c60a70f8a677d7fdca83655a5f489b9
MonoDevelop 3.1.0 - 7affcffdb23e553587fd7c1d6ac120524189b87e

And we observed that after filling out fields we are not getting NRE.