Bug 8752 - [xammac] Cannot set an app icon in info.plist project settings.
Summary: [xammac] Cannot set an app icon in info.plist project settings.
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Mac Add-in ()
Version: 4.0.8
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Aaron Bockover [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2012-12-04 16:38 UTC by Peter Collins
Modified: 2013-06-04 11:53 UTC (History)
3 users (show)

Tags: xamarin mac; xammac
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Peter Collins 2012-12-04 16:38:33 UTC
Clicking the app icon button launches an incomplete 'Select icon...' window that does not allow the user to browse for an image or see any image files located within the project folder shown.

http://screencast.com/t/9dvCjOIfiig

Steps to reproduce:
1) Open a xam mac project in MD
2) Double click on the project folder, or open the info.plist file
3) Click on the button with the text 'No image specified'


Environment Details:
xam mac - 0.9.21
MD 3.1.0 - Build information:
Release ID: 30100000
Git revision: 044fb884195fb864d0d76a75486f84219a3b3a0e
Build date: 2012-12-04 19:55:45+0000
Xamarin addins: bb5d159c2a9933fe17e80f06dae7a58e0d35f1b7

Runtime:
Mono 2.10.11 (mono-2-10/6cee717)
GTK 2.24.13
GTK# (2.12.0.0)
Package version: 210100000
Comment 1 Aaron Bockover [MSFT] 2012-12-06 21:47:34 UTC
This is technically fixed, though I need to make it clear to the user that:

(a) you need to add a .icns file to your project
(b) that .icns file needs to be set as a bundled resource

With that prerequisite satisfied, you should see the icon when setting it in the application options.
Comment 2 Atin 2013-02-07 09:20:22 UTC
We have verified this issue,using following steps :

 1-) Add a .icns file to project. 
 2-) make .icns file as bundled resource.
 3-) right click on project name.
 4-) select MAC OS X application.
 5-) double click on appicon(No image specified).
 6-) select .icns file.

We are successfully able to add .icns file

Enviroment details:
All Mac
Xamarin.Mac 1.0.111
X.S 4.0- 233a86f33176e03e90ab78c67ad70d68c211dcfb

Hence we have changed it to VERIFIED