Bug 8751 - Crash whenever I right-click
Summary: Crash whenever I right-click
Status: RESOLVED DUPLICATE of bug 6630
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 3.0.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-12-04 15:10 UTC by Matthias Fuchs
Modified: 2012-12-10 20:19 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
crashlog (83.13 KB, text/plain)
2012-12-04 15:10 UTC, Matthias Fuchs
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 6630

Description Matthias Fuchs 2012-12-04 15:10:39 UTC
Created attachment 3053 [details]
crashlog

My system: mono 3.0.1
Monodevelop 3.0.5
OSX 10.8.2

Yesterday Monodevelop started to behave oddly. Whenever I right clicked somewhere in the soltions pad, I could not focus the context menu items with the mouse, unless I moved the mouse into the menu while releasing the mouse button.

Today MD simply crashes whenever I right-click.

I tried various older and beta version of both MD and mono and deleted all preferences.

Didn't work at all.

Any ideas?
Comment 1 Mikayla Hutchinson [MSFT] 2012-12-04 20:10:53 UTC

*** This bug has been marked as a duplicate of bug 6630 ***
Comment 2 Mikayla Hutchinson [MSFT] 2012-12-04 20:19:29 UTC
Unfortunately we have not yet been able to track down the cause of this. Pretty much everyone who reported this has found that it went away after a while and didn't happen again. It may be that downgrading Mono to 2.10.x would work around it for now.
Comment 3 Matthias Fuchs 2012-12-09 10:56:35 UTC
I think the problem is somewho cause by some config files, because on a newly created user account the crash doesn't occur.

I deleted following folders without success:
~/.config
~/local
~/Library/MonoDevelop-3.0
~/Library/Preferences/MonoDevelop-3.0

Are there any other user-specific mono/gtk/monodevelop config files to delete?
Comment 4 Mikayla Hutchinson [MSFT] 2012-12-10 20:19:09 UTC
The profile directories are documented here:
http://monodevelop.com/Developers/Articles/User_Profiles

If that doesn't work, it might be something else in your user account, some OS setting or cache, or some utility app?