Bug 8571 - syntax highlighting doesn't seem to work in conditional sections
Summary: syntax highlighting doesn't seem to work in conditional sections
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 3.0.x
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2012-11-23 11:33 UTC by Philippe Monteil
Modified: 2012-11-26 03:51 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Philippe Monteil 2012-11-23 11:33:31 UTC
the problem is produced by the code below:


#define _TEST_

using System;

namespace test
{

    public class CTest
    {

        public CTest()
        {
            int i=0;
        }

        void Test()
        {
            CTest _pCTest = null; // 'CTest' appears in green
            _pCTest=new CTest();
        }

#if _TEST_
        void _Test()
        {
            CTest _pCTest = null; // 'CTest' does not appear in green
            _pCTest=new CTest();
        }
#endif

    }

}
Comment 1 Mike Krüger 2012-11-26 02:28:54 UTC
fixed
Comment 2 Philippe Monteil 2012-11-26 03:18:49 UTC
Thanks: Xamarin's reactivity is constant and always appreciated!
Comment 3 Mike Krüger 2012-11-26 03:51:21 UTC
you had luck I'm just back from a 2 week long FTO :)