Bug 8568 - Deploy to FUSE fails when creating directory
Summary: Deploy to FUSE fails when creating directory
Status: RESOLVED INVALID
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Deployment ()
Version: 3.0.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-11-23 09:38 UTC by Ali
Modified: 2012-11-23 12:15 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Ali 2012-11-23 09:38:07 UTC
When trying to 'Deploy to web' using FUSE a directory is first added:

"/var/folders/_c/nkbdg9n1479gr6jy7hyw8jhh0000gn/T/md-deploy-penx634892773019606550/bin"

This is returning access denied on my system, I think because the parent directory has not yet been created (the user that is running monodevelop has write access to /var/folders/_c/nkbdg9n1479gr6jy7hyw8jhh0000gn/T).


Stack trace:

System.UnauthorizedAccessException: Access to the path "/var/folders/_c/nkbdg9n1479gr6jy7hyw8jhh0000gn/T/md-deploy-penx634892773019606550/bin" is denied.
  at System.IO.Directory.CreateDirectoriesInternal (System.String path) [0x0006c] in /private/tmp/source/bockbuild/profiles/mono-mac-release/build-root/mono-2.11/_build/mono-2.11.git/mcs/class/corlib/System.IO/Directory.cs:121 
  at System.IO.Directory.CreateDirectory (System.String path) [0x000a4] in /private/tmp/source/bockbuild/profiles/mono-mac-release/build-root/mono-2.11/_build/mono-2.11.git/mcs/class/corlib/System.IO/Directory.cs:83 
  at MonoDevelop.Deployment.Targets.LocalFileCopyHandler.EnsureDirectoryExists (System.String directory) [0x0000b] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-3.0-series/e159cf08/source/monodevelop/main/src/addins/Deployment/MonoDevelop.Deployment/MonoDevelop.Deployment.Targets/LocalFileCopyHandler.cs:233 
  at MonoDevelop.Deployment.Targets.LocalFileCopyHandler.InternalCopyFiles (IProgressMonitor monitor, IFileReplacePolicy replacePolicy, MonoDevelop.Deployment.FileCopyConfiguration copyConfig, MonoDevelop.Deployment.DeployFileCollection deployFiles, MonoDevelop.Deployment.DeployContext context, System.String realPrefix) [0x0025c] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-3.0-series/e159cf08/source/monodevelop/main/src/addins/Deployment/MonoDevelop.Deployment/MonoDevelop.Deployment.Targets/LocalFileCopyHandler.cs:133 
  at MonoDevelop.Deployment.Targets.BaseFuseFileCopyHandler.CopyFiles (IProgressMonitor monitor, IFileReplacePolicy replacePolicy, MonoDevelop.Deployment.FileCopyConfiguration copyConfig, MonoDevelop.Deployment.DeployFileCollection deployFiles, MonoDevelop.Deployment.DeployContext context) [0x00060] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-3.0-series/e159cf08/source/monodevelop/main/src/addins/Deployment/MonoDevelop.Deployment/MonoDevelop.Deployment.Targets/BaseFuseFileCopyHandler.cs:66 
  at MonoDevelop.Deployment.FileCopyHandler.CopyFiles (IProgressMonitor monitor, IFileReplacePolicy replacePolicy, MonoDevelop.Deployment.FileCopyConfiguration copyConfig, MonoDevelop.Deployment.DeployFileCollection files, MonoDevelop.Deployment.DeployContext context) [0x00000] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-3.0-series/e159cf08/source/monodevelop/main/src/addins/Deployment/MonoDevelop.Deployment/MonoDevelop.Deployment/FileCopyHandler.cs:64 
  at MonoDevelop.Deployment.FileCopyConfiguration.CopyFiles (IProgressMonitor monitor, IFileReplacePolicy replacePolicy, MonoDevelop.Deployment.DeployFileCollection files, MonoDevelop.Deployment.DeployContext context) [0x00000] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-3.0-series/e159cf08/source/monodevelop/main/src/addins/Deployment/MonoDevelop.Deployment/MonoDevelop.Deployment/FileCopyConfiguration.cs:74 
  at MonoDevelop.AspNet.Deployment.WebDeployService.DoDeploy (System.Object o) [0x0003b] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-3.0-series/e159cf08/source/monodevelop/main/src/addins/AspNet/MonoDevelop.AspNet/MonoDevelop.AspNet.Deployment/WebDeployService.cs:93
Comment 1 Ali 2012-11-23 12:07:25 UTC
For some reason the root of my sshfs is mounting as read-only even though I have access. Likely a problem with sshfs so marked resolved.
Comment 2 Ali 2012-11-23 12:15:22 UTC
this seems to be a bug with MacFUSE/OSXFUSE, though I can get around it by setting my username in mono-develop to:

-o defer_permissions username

See:
http://www.mail-archive.com/macfuse@googlegroups.com/msg01238.html