Bug 8562 - [VS/Debug only]When try to debug any application on the API-17 Android 4.2 JellyBean emulator, it gives an error and does not deploy the application.
Summary: [VS/Debug only]When try to debug any application on the API-17 Android 4.2 Je...
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 4.4.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-11-23 05:54 UTC by Jatin
Modified: 2013-05-29 09:49 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Jatin 2012-11-23 05:54:26 UTC
Steps to reproduce:
1. Launch VS 2012/VS 2010.
2. Create any MFA application or Open any existing application.
3. Set the tearget framework of the application as Android 4.2 JellyBean from Project Properties.
4. Debug the application on the emulator of API-17 (Android 4.2 JellyBean)
5. Observe that the application does not deploy to device and gives the exception.

Actual result: When Debug any application on the emulator of API-17 Android 4.2 Jelly Bean with the target framework of the application set as Android 4.2 Jelly Bean, the application does not deploy to device and it gives the unhandled exception: "Unhandled exception in InstallSharedPlatform." Below is the screencast of the stack Trace for the same: http://www.screencast.com/t/4DpU2cXB

Expected result: The user should successfully able to debug/run the application with the target framework as Android 4.2 Jelly Bean on the emulator of API-17.

Environment information:
Windows 7 and 8
VS 2012/VS 2010
MFA 4.4.27.70430532 - 432af4490489b682f622f391539e628052784024

Regression Status: Not able to provide regression status, as this feature was not available with the stable version of MFA and MD.
Comment 1 narayanp 2012-11-27 11:16:45 UTC
Today, we have verified this issue with following build:

MD 3.0.5 - d6e46ae022e8016c8ca548619a91e155ce2f5530
MFA 4.4.29.91873776 -579e1f0c8df4cb35842e4927c738cdbb9671154e

This issue does not exist with MD, we are able to DEBUG the application on the emulator of API-17 (Android 4.2 JellyBean) successfully.
Comment 2 Saurabh 2012-12-04 10:32:39 UTC
Today we verified this issue using following builds:

mono-android-4.4.40.242769865 - e785fc9cbf20440d09988327bdaf614804d55a21
VisualStudio 2010/2012

We are able to deploy the application in debug mode on emulator API-17
Comment 3 PJ 2012-12-04 11:26:10 UTC
Ok marking as fixed then based on comment 2
Comment 4 Mohit Kheterpal 2013-05-29 09:49:05 UTC
Today we have checked this issue on following builds :

Windows 7 / 8
VS 2010 / 2012
MFA 4.6.07004

Now we can able to debug/run the application successfully with the target framework as Android 4.2 Jelly Bean on the emulator of API-17.

Hence changing its status to verified fixed.