Bug 8500 - The entry point method could not be loaded
Summary: The entry point method could not be loaded
Status: RESOLVED ANSWERED
Alias: None
Product: Runtime
Classification: Mono
Component: General ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Alexander Kyte
URL:
Depends on:
Blocks:
 
Reported: 2012-11-19 08:02 UTC by Aaron
Modified: 2017-08-28 15:05 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Comment 1 Alexander Kyte 2015-04-02 19:03:03 UTC
I can confirm that this bug is still present in mono 4.1.0.
Comment 4 Alexander Kyte 2015-04-03 15:06:39 UTC
The error seen is a type load error in disguise. It can't find Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase. If you set your path correctly, it should be able to find the entry point.

ex:

MONO_PATH=/Library/Frameworks/Mono.framework/Versions/Current/lib/mono/gac/Microsoft.VisualBasic/11.0.0.0__b03f5f7f11d50a3a/:$MONO_PATH mono <executable>.exe

Although with that I still had the libgdiplus.dylib loading problem.
Comment 5 Rodrigo Kumpera 2015-04-03 15:21:16 UTC
It works with the mono 4.0 package.

The usual problem here is that you don't have the VB libs installed.