Bug 8432 - Error MT0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com (MT0000)
Summary: Error MT0000: Unexpected error - Please file a bug report at http://bugzilla....
Status: RESOLVED NORESPONSE
Alias: None
Product: iOS
Classification: Xamarin
Component: Debugger ()
Version: 6.1.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-11-15 14:32 UTC by s.riedler
Modified: 2014-04-15 08:12 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description s.riedler 2012-11-15 14:32:30 UTC
The simulator works fine in Debug-Mode, but when I want to debug my App on my iPhone 5 (iOS 6.0.1) I get this error message. I'm using the latest versions of XCode and MonoTouch.

error MT0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com
System.ComponentModel.Win32Exception: ApplicationName='/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/gcc', CommandLine=' -miphoneos-version-min=5.0 -gdwarf-2  -arch armv7  -std=c99 -I/Developer/MonoTouch/SDKs/MonoTouch.iphoneos.sdk/usr/include -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS6.0.sdk -c /var/folders/ss/8gyr1fvn73lc124d_s96_mv80000gn/T/tmp431dd144.tmp/main.armv7.m -o /Users/Stefan/Dropbox/n'stuff/Revolution2_20121005/Revolution2/obj/Debug/mtouch-cache/main..armv7.cache.heX+if+Fn760x7+Q6R49Y4GV8UI=.o', CurrentDirectory=''
  at System.Diagnostics.Process.Start_noshell (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) [0x00000] in <filename unknown>:0 
  at System.Diagnostics.Process.Start_common (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) [0x00000] in <filename unknown>:0 
  at System.Diagnostics.Process.Start (System.Diagnostics.ProcessStartInfo startInfo) [0x00000] in <filename unknown>:0 
  at MTouch.RunCommand (System.String path, System.String args, System.String[] env, System.Func`2 processOutput) [0x00000] in <filename unknown>:0 
  at MTouch.Compile (System.String ifile, System.String ofile, System.String kind, Abi abi) [0x00000] in <filename unknown>:0 
  at MTouch.CompileObjC (System.String ifile, System.String ofile, Abi abi) [0x00000] in <filename unknown>:0 
  at MTouch.GetObjectFileForSource (System.String sourceFile, Abi abi) [0x00000] in <filename unknown>:0 
  at MTouch+<Main2>c__AnonStorey10.<>m__59 (Abi abi) [0x00000] in <filename unknown>:0 
  at System.Threading.Tasks.Parallel+<ForEach>c__AnonStorey36`1[MTouch+Abi].<>m__34 (Abi e, System.Threading.Tasks.ParallelLoopState s, System.Object l) [0x00000] in <filename unknown>:0 
  at System.Threading.Tasks.Parallel+<ForEach>c__AnonStorey35`2[MTouch+Abi,System.Object].<>m__32 () [0x00000] in <filename unknown>:0 
  at System.Threading.Tasks.TaskActionInvoker+ActionInvoke.Invoke (System.Threading.Tasks.Task owner, System.Object state, System.Threading.Tasks.Task context) [0x00000] in <filename unknown>:0 
  at System.Threading.Tasks.Task.InnerInvoke () [0x00000] in <filename unknown>:0 
  at System.Threading.Tasks.Task.ThreadStart () [0x00000] in <filename unknown>:0
Comment 1 Sebastien Pouliot 2012-11-15 15:20:15 UTC
A missing gcc compiler does not normally end up with this error. Can you please provide all the versions information of your system ?

You can get them from "MonoDevelop" menu, "About MonoDevelop" item, "Version Information" tab. Click on the "Copy Version Information" button and paste this into this bug report.
Comment 2 s.riedler 2012-11-15 16:03:09 UTC
########################################################
MonoDevelop 3.0.5
Installation UUID: 0034706b-1348-4ba6-91d1-bb34148cb442
Runtime:
	Mono 2.10.9 (tarball)
	GTK 2.24.10
	GTK# (2.12.0.0)
	Package version: 210090011
Apple Developer Tools:
	 Xcode 4.5.2 (1847)
	 Build 4G2008a
Mono for Android: Not Installed

Monotouch: 6.0.6
Build information:
	Release ID: 30005000
	Git revision: e159cf083bd327933166819d94245298898d6e3d
	Build date: 2012-10-24 16:43:06+0000
	Xamarin addins: eea2ed91ae8dd242b281d5ec8f6c2fbc63b4cd3d
Operating System:
	Mac OS X 10.8.2
	Darwin macbook-pro.home 12.2.1 Darwin Kernel Version 12.2.1
	    Thu Oct 18 12:13:47 PDT 2012
	    root:xnu-2050.20.9~1/RELEASE_X86_64 x86_64
########################################################


I "simply" solved this problem - I created a new project and added all the files I needed for my App - then I was able to debug my app on my iPhone again!
Comment 3 Sebastien Pouliot 2012-11-15 16:08:38 UTC
Could you attach the old .sln and .csproj files (you can mark them private) to the bug report ? something has gone wrong and we'd like to see how we can avoid this. Thanks
Comment 6 s.riedler 2012-11-15 16:13:32 UTC
I just added both files - I hope you will be able to fix this problem!
Comment 7 PJ 2013-11-19 17:05:24 UTC
This bug has been in the NEEDINFO state with no changes for the last 90 days. Can we put this back into the NEW or CONFIRMED state, or are we still awaiting response?

If there is no change in the status of this bug over the next two weeks, this bug will be marked as NORESPONSE.
Comment 8 PJ 2013-12-05 18:35:45 UTC
This bug has not been changed from the NEEDINFO state since my previous comment, marking as RESOLVED NORESPONSE.

Please feel free to REOPEN this bug at any time if you are still experiencing the issue. Please add the requested information and set the bug back to the NEW (or CONFIRMED) state.
Comment 9 dj_technohead 2014-04-15 02:20:07 UTC
I was able to reproduce this error with a project compiling for a  physical device and linker behavior set to "Link all assemblies". 

error MT0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com
System.NullReferenceException: Object reference not set to an instance of an object
  at MonoTouch.Registrar.TypeSystemDescriptor.TryGetAttribute (ICustomAttributeProvider provider, System.String namespace, System.String attributeName, Mono.Cecil.CustomAttribute& attribute) [0x00000] in <filename unknown>:0 
  at MonoTouch.Registrar.TypeSystemDescriptor.GetSuperClassName (Mono.Cecil.TypeDefinition type) [0x00000] in <filename unknown>:0 
  at MonoTouch.Registrar.TypeSystemDescriptor.ProcessType (Mono.Cecil.TypeDefinition type) [0x00000] in <filename unknown>:0 
  at MonoTouch.Registrar.TypeSystemDescriptor.ProcessType (Mono.Cecil.TypeDefinition type) [0x00000] in <filename unknown>:0 
  at MonoTouch.Registrar.TypeSystemDescriptor.ProcessAssembly (Mono.Cecil.AssemblyDefinition assembly) [0x00000] in <filename unknown>:0 
  at MonoTouch.Registrar.TypeSystemDescriptor.Process (IEnumerable`1 assemblies) [0x00000] in <filename unknown>:0 
  at MonoTouch.Registrar.TypeSystemDescriptor.Describe (IEnumerable`1 assemblies) [0x00000] in <filename unknown>:0 
  at MonoTouch.Registrar.OldStaticRegistrar.Generate (IEnumerable`1 assemblies) [0x00000] in <filename unknown>:0 
  at MTouch.RunRegistrar (System.Collections.Generic.List`1 assemblies, System.String assemblies_path, System.String output_dir, Boolean old, System.String out_file) [0x00000] in <filename unknown>:0 
  at MonoTouch.Application.Compile () [0x00000] in <filename unknown>:0 
  at MonoTouch.Application.BuildApp () [0x00000] in <filename unknown>:0 
  at MonoTouch.Application.Build () [0x00000] in <filename unknown>:0 
  at MTouch.Main2 (System.String[] args) [0x00000] in <filename unknown>:0 
  at MTouch.Main (System.String[] args) [0x00000] in <filename unknown>:0
Comment 10 Sebastien Pouliot 2014-04-15 08:12:55 UTC
Same (default, uncatched) error but a different stacktrace (i.e. a different issue).

Please file a separate bug report and include all verison infromations* and a test case so we can reproduce the issue,. Thanks

* The easiest way to get exact version information is to use the "Xamarin Studio" menu, "About Xamarin Studio" item, "Show Details" button and copy/paste the version informations (you can use the "Copy Information" button).