Bug 8340 - Java Binding Library project doesn't work if # is in path
Summary: Java Binding Library project doesn't work if # is in path
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: Bindings ()
Version: 4.2.x
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Atsushi Eno
URL:
Depends on:
Blocks:
 
Reported: 2012-11-12 11:14 UTC by Sebastian Krysmanski
Modified: 2013-06-21 05:44 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Sebastian Krysmanski 2012-11-12 11:14:32 UTC
If the path to a "Java Bindings Library" project contains a # character (like in "D:\C#\MyProject"), the binding process will silently fail (in Visual Studio 2012). If the build verbosity is set to at least "Normal", the binding step will report for each class in the jar file "Class couldn't be loaded" but no further information is provided.

Please fix this or at least provide some kind of error message.
Comment 2 Atsushi Eno 2013-06-21 05:44:54 UTC
We had some path issue in the past, and I tried this works in the latest version. I believe both stable and alpha works, but in case stable didn't work, please try alpha or wait for the next major upgrade in stable release.