Bug 822 - Issues with outlining in 2.6 Snow Leopard
Summary: Issues with outlining in 2.6 Snow Leopard
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 2.6
Hardware: Macintosh All
: Normal normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2011-09-14 17:16 UTC by Chris Hardy [MSFT]
Modified: 2011-12-07 05:27 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Chris Hardy [MSFT] 2011-09-14 17:16:31 UTC
I just updated to v2.6 running on Snow Leapord and I'm having some issues with the outlining. 

Sometimes when I collapse a region, the mouse cursor is unable to select the line it is currently hovering over, instead selecting a line above its current location when I click. Also, having inserted a line of code, I have noticed that the automatic outlining of methods and properties occurs in the wrong place, offering me the option to collapse a region that is already a couple of lines into the method, but not the method itself.
Comment 2 Leonardo Mosquera 2011-09-29 12:43:08 UTC
Confirming the same behaviour on 2.6.0.1 compiled from source on Ubuntu 11.04; using Mono 2.10.5 (also compiled from source).

This usually happens after I "Toggle all folds" (shift+ctrl+a).

In addition to what Chris Hardy described, when I select lines over a closed region, the region opens up, which doesn't happen before the erratic behaviour starts (that is, selecting a closed region doesn't open it).

The syptoms go away after restarting Monodevelop.
Comment 3 Mike Krüger 2011-12-07 05:27:15 UTC
Fixed in 2.8. The collapsing algorithm got replaced.