Bug 8194 - It is not possible to debug ASP.NET application (F5) more than once.
Summary: It is not possible to debug ASP.NET application (F5) more than once.
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: ASP.Net ()
Version: 3.0.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-11-03 13:37 UTC by pinggi
Modified: 2015-09-17 07:12 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot of the error (138.04 KB, image/png)
2012-11-03 13:37 UTC, pinggi
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description pinggi 2012-11-03 13:37:10 UTC
Created attachment 2849 [details]
Screenshot of the error

1. Open ASP.NET project
2. Run it in debug mode (F5) - browser will show the front page
3. Go back to Monodevelop and stop debug mode (shift + F5)
4. Debug mode is stopped, run it again in debug mode (F5)
5. Following error is displayed:

Adding applications '/:.'...

Registering application:
    Host:          any
    Port:          any
    Virtual path:  /
    Physical path: C:\MonoDevelop\ASPNetMVCTest\ASPNetMVCTest\

xsp4

Listening on address: 127.0.0.1Root directory: C:\MonoDevelop\ASPNetMVCTest\ASPNetMVCTest

Error: System.Net.Sockets.SocketException: Only one usage of each socket address (protocol/network address/port) is normally permitted.


  at System.Net.Sockets.Socket.Bind (System.Net.EndPoint local_end) [0x00000] in <filename unknown>:0 
  at Mono.WebalException) [0x00000] in <filename unknown>:0 
  at (wrapper remoting-invoke-with-check) Mono.WebServer.ApplicationServer:Start (bool,System.Exception)
  at Mono.WebServer.XSP.Server.RealMain (System.String[] args, Boolean root, IApplicationHost ext_apphost, Boolean quiet) [0x00000] in <filename unknown>:0 
Server.XSPWebSource.CreateSocket () [0x00000] in <filename unknown>:0 
  at Mono.WebServer.ApplicationServer.Start (Boolean bgThread) [0x00000] in <filename unknown>:0 
  at Mono.WebServer.ApplicationServer.Start (Boolean bgThread, System.Exception initi



6. Now you cant't run application in debug mode! You need to start task manager and through it kill "mono.exe *32" process.

7. After you kill the process, you are able to run the web app again in debug mode by pressing F5.

8. So it seems that stopping debug mode in Monodevelop does not stop the app process.
Comment 1 Matt Ward 2015-09-17 07:12:10 UTC
Unable to reproduce this with MonoDevelop 5.9. So it looks like the problem has been fixed.