Bug 8045 - Deployment does not work when there are spaces in the project path
Summary: Deployment does not work when there are spaces in the project path
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Dominique Louis
URL:
Depends on:
Blocks:
 
Reported: 2012-10-29 10:44 UTC by Dimitar Dobrev
Modified: 2016-08-03 15:23 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Dimitar Dobrev 2012-10-29 10:44:28 UTC
If an Android project is located at a path with spaces, it cannot be deployed, at least to an emulator. Instead I get the following error:

Packaging application..
Microsoft (R) Build Engine Version 4.0.30319.1
[Microsoft .NET Framework, Version 4.0.30319.269]
Copyright (C) Microsoft Corporation 2007. All rights reserved.

MSBUILD : error MSB1008: Only one project can be specified.
Switch: <some_path_with_spaces>\MonoForAndroidProject.csproj

For switch syntax, type "MSBuild /help"
Comment 1 Dimitar Dobrev 2012-10-31 10:52:56 UTC
Actually, the same happens with no spaces in the path.
Comment 2 Dimitar Dobrev 2012-11-01 10:14:14 UTC
The problem was actually that our build configuration in its name - "Android Debug". I renamed it to "Android_Debug" and it worked.
Comment 3 Dimitar Dobrev 2012-11-01 10:14:42 UTC
"had a space in its name"
Comment 4 Jonathan Pryor 2012-11-01 19:46:56 UTC
Dominique: Do you know how VS builds a given project configuration, and if the VS add-in is involved?
Comment 5 Atsushi Eno 2013-05-22 14:51:01 UTC
I believe this was fixed in our MSBuild task. If it still reproduces. please reopen.
Comment 6 Daniel 2013-10-14 07:46:44 UTC
This happens for me with Xamarin.Android 4.8.3. My project path has no spaces but the Build configuration name has.
Comment 7 Atsushi Eno 2013-10-14 08:44:52 UTC
Please file another bug with reproducible project for such a different issue. Thanks.