Bug 8040 - Designer losing my work
Summary: Designer losing my work
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: Designer ()
Version: 4.2.x
Hardware: PC Windows
: High normal
Target Milestone: ---
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2012-10-29 06:04 UTC by Dylan
Modified: 2012-12-12 07:26 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Dylan 2012-10-29 06:04:20 UTC
This is now the third time I have lost changes whilst using MonoDevelop's Android designer. My other developers have noticed a similar thing. I was working on about 5 different layouts, and upon reopening MonoDevelop the layouts are completely empty.  

I am not sure how I have managed to get this right. But basically the .axml files were in a saved state (no * in the tab) and upon closing MonoDevelop there was no dialog asking me to save my files so I assumed everything had been saved. 

M4A 4.2.6
MonoDevelop 3.0.4.7
Comment 1 Lluis Sanchez 2012-12-12 07:26:45 UTC
This has been fixed. The fix will be included in upcoming releases. I'll update this bug report with the exact version that includes the fix.