Bug 8019 - Random clear ViewController code on back from XCode. (Possible bug on rebuild when Navigator is hidded)
Summary: Random clear ViewController code on back from XCode. (Possible bug on rebuild...
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-10-26 11:37 UTC by Jose Medrano
Modified: 2016-03-15 21:20 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sometimes this error (653.49 KB, image/png)
2012-10-26 11:38 UTC, Jose Medrano
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jose Medrano 2012-10-26 11:37:32 UTC
I create the project, Draw on XCode designer all windows and outlets etc... (All on graphical mode)

I'm on Xcode. When I write code and Navigation window is hidden. I add elements on UI with their outlets. If back to Monodroid without Saving, on back to Xcode classes are empty (ViewController.cs). 

Sometimes it only clean ViewController.designer.cs class, sometimes all two and sometimes it gives me a error Xcode + clean.

Screenshot added.

Thanks
Comment 1 Jose Medrano 2012-10-26 11:38:13 UTC
Created attachment 2798 [details]
Sometimes this error
Comment 2 Jeffrey Stedfast 2016-03-15 21:20:08 UTC
This has probably long since been fixed