Bug 8000 - MonoDevelop runs out of memory
Summary: MonoDevelop runs out of memory
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 3.0.x
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2012-10-25 15:32 UTC by Allie Miller
Modified: 2012-11-05 05:21 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Allie Miller 2012-10-25 15:32:23 UTC
Case #18496

With a large native library for MonoTouch bindings and link into to a MonoTouch app. The .a is about 250MB with i386, armv7 and armv7s architectures. MonoDevelop runs out of memory frequently when building and sometimes when doing non-build operations. When MonoDevelop is quit, it stops responding and it must be force closed.

Static library and MonoDevelop logs attached to case.

Issue should be triggered after repeated rebuilds. 

In first attempt at reproducing the problem, MonoDevelop's memory usage went up to 2.47GB after 3 rebuilds of the project, then produced the out of memory error on the 4th rebuild. Trying to reproduce it again, memory usage worked up to 2.2GB, then back down to 1.6GB after repeated rebuilds.


System information below:
MonoDevelop 3.0.4.7
Installation UUID: 08b0a221-0745-4003-b3f3-20a6e52a5868
Runtime:
Mono 2.10.9 (tarball)
GTK 2.24.10
GTK# (2.12.0.0)
Package version: 210090011
Apple Developer Tools:
Xcode 4.5 (1839)
Build 4G182
Monotouch: 6.0.4
Mono for Android: Not Installed

Build information:
Release ID: 30004007
Git revision: ea0108260c6a376ecaeffcdb7d03387bd51edda3
Build date: 2012-09-17 14:09:17+0000
Xamarin addins: ec43fd5cb223ead4234a9858d1b56eef03dad53a-dirty
Operating System:
Mac OS X 10.8.2
Darwin WS1379.local 12.2.0 Darwin Kernel Version 12.2.0
Sat Aug 25 00:48:52 PDT 2012
root:xnu-2050.18.24~1/RELEASE_X86_64 x86_64
Comment 18 Mike Krüger 2012-11-05 05:21:50 UTC
marking it as fixed.