Bug 80 - MD Unhandled Exception - Debugging Console app on OS/X
Summary: MD Unhandled Exception - Debugging Console app on OS/X
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: 2.4.2
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2011-07-27 09:18 UTC by Ethan Nagel
Modified: 2011-11-14 16:27 UTC (History)
3 users (show)

Tags: debugging console OS/X
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Ethan Nagel 2011-07-27 09:18:39 UTC
I'm using MD to debug through a console application and on attempting to step through the debugger I get the following error in a modal popup:

System.ArgumentNullException: Argument cannot be null.
Parameter name: thread
  at Mono.Debugger.Soft.StepEventRequest..ctor (Mono.Debugger.Soft.VirtualMachine vm, Mono.Debugger.Soft.ThreadMirror thread) [0x00000] in <filename unknown>:0 
  at Mono.Debugger.Soft.VirtualMachine.CreateStepRequest (Mono.Debugger.Soft.ThreadMirror thread) [0x00000] in <filename unknown>:0 
  at Mono.Debugging.Soft.SoftDebuggerSession.<OnStepLine>m__F (System.Object ) [0x00000] in <filename unknown>:0 

"Monodevelop will now close".  Yep it will.
Comment 1 Miguel de Icaza [MSFT] 2011-08-23 09:54:20 UTC
Ethan,

Does this bug still happen with the new version of Mono on Lion?

I was not able to replicate it.
Comment 2 Alan McGovern 2011-11-14 16:27:28 UTC
I believe this has been fixed as no-one can reproduce this. If the issue is still there could you give more detailed information on what mono and monodevelop version you have installed so we can try to reproduce it. Also, it'd help if you could check on the latest versions of MonoDevelop and mono if you are on old versions.