Bug 7983 - [iOS 6.0] Phone does not vibrate after clicking on 'Vibrate' and 'Alert Sound' in SysSound application
Summary: [iOS 6.0] Phone does not vibrate after clicking on 'Vibrate' and 'Alert Sound...
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Samples ()
Version: 6.0.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-10-25 07:42 UTC by Saurabh
Modified: 2013-06-17 09:38 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Saurabh 2012-10-25 07:42:17 UTC
Steps to reproduce this issue:
1. Open MD.
2. Open SysSound application.
3. Debug/Run the application.
4. Click  'Vibrate' and 'Alert Sound' in SysSound.

Actual result: Phone does not vibrate after clicking 'Vibrate' and 'Alert Sound' in SysSound on iOS 6 devices. While on iOS 5 devices this is working fine.


Expected result: Phone should vibrate after clicking 'Vibrate' and 'Alert Sound' in SysSound.

Supplement info:
https://gist.github.com/3952091
MD log:
https://gist.github.com/3952103

Environment details:
All Mac
MD 3.0.5 e159cf083bd327933166819d94245298898d6e3d
MT 6.0.5 3821681a8a937617387f076c5749227ea7fe7413
Mono 2.10.9_11 Stable

Debug Vs Release:
This is happening on both debug and release mode.

Device info:
iPhone/iPod
Version 6.0

App info:
SysSound/xamarin-monotouch-samples-33efa2f

Regression status:
NOT A REGRESSION: This is also happening with MT 6.0.4 Stable
Comment 1 Ray Kelly 2013-04-21 10:26:17 UTC
Is this bug still being worked on?  I cant find any way to make the phone vibrate even using the code examples.

Thanks.
Comment 2 Bo Pang 2013-06-14 17:35:05 UTC
I tested this bug with iPhone 5 with iOS6 and did not find the issue. The phone do vibrate after clicking 'Vibrate' and 'Alert Sound'.
Comment 3 narayanp 2013-06-17 09:37:52 UTC
Today I have checked this issue with following builds:

X.S 4.0.7-1
Xamarin.iOS 6.3.6-76
Mono 3.0.11

Phone do vibrate after clicking on 'Vibrate' and 'Alert Sound' checked this on iPhone5 version 6.0.2

But iPod Touch does not vibrate because it does not contain vibration feature.

Hence closing this feature.
Comment 4 narayanp 2013-06-17 09:38:13 UTC
Closing this Bug