Bug 7951 - Cursor jumps to end of line after typing first character in XML comment element
Summary: Cursor jumps to end of line after typing first character in XML comment element
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: C# Binding ()
Version: 3.0.x
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2012-10-23 15:52 UTC by Len Charest
Modified: 2012-10-25 05:34 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Len Charest 2012-10-23 15:52:46 UTC
Given an existing XML comment on a property as follows:

    /// <summary>
    /// Gets or sets a value indicating whether this instance is frobbed.
    /// </summary>
    protected bool IsFrobbed { get; set; }

If I want to add another element (e.g., <remarks/>) and I type "<remarks>", MD inserts the closing tag and keeps the cursor positioned between the tags. However, immediately after typing the first character of the comment content, the cursor jumps past the closing tag to the end of the line.

Visually:

    /// <remarks>|</remarks>

The cursor is indicated by "|" above. Now, If I type "A", MD will move the cursor as follows:

    /// <remarks>A</remarks>|

The unexpected cursor movement is the bug.
Comment 1 Mike Krüger 2012-10-25 05:34:32 UTC
We've fixed it internally - but it'll take some time to release the version. (It was planned to release this month, but we needed to delay it)
It looks maybe easy, but there are some components involved in this issue :/ - would be hard to backport it to the master branch.