Bug 7921 - For any MFA application when the user select all the build output through 'command + a' and then try to copy it using 'command + c', it does not get copied.
Summary: For any MFA application when the user select all the build output through 'co...
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 3.0.x
Hardware: All All
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-10-22 06:19 UTC by Nischal
Modified: 2013-05-21 09:08 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Nischal 2012-10-22 06:19:44 UTC
Steps to reproduce:
1. Open any MFA application.
2. Remove the semi-colon from any line so that it may effect in the build
error.
3. Build the application.
4. Now click inside the Build output window, and try to select all through
'command + a'.
5. Now try to copy the entire text using: 'command + c'
6. Observe that the text does not get copied successfully.

Actual result: For any MFA application when try to copy the build output using "command + c", the text does not get copied successfully. However, when try to copy the same text through Right click >> Copy, it get copied successfully.

Expected result: For any MFA application when try to copy the build output using "command + c", the text should always get copied successfully. the way it does when copy through Right click >> Copy.

Environment information:
All Mac and all windows
MFA 4.3.129.148464198 - 8d96246b735a14552c70f72f2cffedc12d26f709
MD 4.0 - 56b4e889d5855b3f7ba5ac204adbc3863829050c

Regression status: Not a REGRESSION, as this issue exists with the stable version of MD and MFA.
Comment 1 Alan McGovern 2012-11-05 12:37:55 UTC
Implemented in commit 44c06a93d8cb27760ca9fcbb4e5ffd8b286a897e in monodevelop/master
Comment 2 narayanp 2012-11-07 07:33:08 UTC
Today, we have verified this issue with following build:

MD 4.0 - 914a3a320f19354928bc0eac9704db88296e806d
MT 6.0.4  (stable)
MFA 4.2.7 (Stable)
Mono Framework 2.10.10 - a0f2930ea5c6042ff896c137fa138bba8ebbdb9c

The user is able to select all the build output through 'command + a' and the selected area gets highlighted blue. And when user copy it using 'command + c', it gets copied successfully. But the highlighting of the selected area gets disappeared for which we have reported another issue bug 8258
Comment 3 Nischal 2013-05-21 09:08:41 UTC
As per comment#2 changing the status of this bug to Verified.