Bug 792 - Mono does not support quoted values in MONO_ENV_OPTIONS
Summary: Mono does not support quoted values in MONO_ENV_OPTIONS
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: General ()
Version: unspecified
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 3785 ()
Depends on:
Blocks:
 
Reported: 2011-09-13 16:27 UTC by googlly.element109
Modified: 2012-03-10 10:45 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description googlly.element109 2011-09-13 16:27:19 UTC
On OSX Lion 

1. open a project in Users/UserName/Samples/MonoMac Samples/someproject.sln
2. click the run or debug button, message appears can't locate output

If this is normal behavior for OSX, please forgive my ignorance.
Comment 1 Mikayla Hutchinson [MSFT] 2011-09-13 16:49:22 UTC
This is a bug in the the way the MonoMac launch script launches Mono. Unfortunately there are only really two ways to fix it:
a) alter Mono to handle quoting in MONO_ENV_OPTIONS
b) use a stub launcher executable that loads Mono as a dynamic library, instead of using a launch script
Comment 2 Mikayla Hutchinson [MSFT] 2012-02-17 17:12:14 UTC
This specific bug could be fixed by allowing quoted values in the MONO_ENV_OPTIONS environment variable. Reassigning to Mono.
Comment 3 Mikayla Hutchinson [MSFT] 2012-03-07 15:06:29 UTC
*** Bug 3785 has been marked as a duplicate of this bug. ***
Comment 4 Zoltan Varga 2012-03-10 10:45:12 UTC
Fixed in HEAD/2.10.