Bug 788 - ConfigurationSection.ElementInformation.IsPresent always false
Summary: ConfigurationSection.ElementInformation.IsPresent always false
Status: NEW
Alias: None
Product: Class Libraries
Classification: Mono
Component: System.Configuration ()
Version: 2.10.x
Hardware: Other Linux
: Low normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-09-13 15:50 UTC by marv007+xamarinbugz
Modified: 2018-03-13 14:06 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Example project for MonoDevelop 2.6 beta 3 (5.77 KB, application/gzip)
2011-09-13 15:50 UTC, marv007+xamarinbugz
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 788 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description marv007+xamarinbugz 2011-09-13 15:50:20 UTC
Created attachment 350 [details]
Example project for MonoDevelop 2.6 beta 3

Overview:
When reading a configsection from a config file the IsPresent property is always false even if it exists and was read. 

Steps to Reproduce:
Use attachment

Actual Results:
a.ElementInformation.IsPresent = false

Expected Results:
a.ElementInformation.IsPresent = true

Build Date & Platform:
Mono 2.10.5 on Ubuntu 11.04

Additional Builds and Platforms:
Doesn't Occur On MS .NET on Windows 7 Pro x64 SP1 and I'm quite sure it worked on SP0 just as well.
Comment 1 JohnHarris 2016-10-05 10:52:51 UTC
  Thanks for the solution. I will inform people from http://essaydune.com/essays-for-sale/ about this update so they could fix the problem they have been informing me about all the time. Thank you.