Bug 7873 - Code Completion not working and ~/.config/MonoDevelop missing
Summary: Code Completion not working and ~/.config/MonoDevelop missing
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: C# Binding ()
Version: 3.0.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2012-10-16 16:22 UTC by Allie Miller
Modified: 2012-10-18 00:05 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Allie Miller 2012-10-16 16:22:44 UTC
Case #18537

Customer is having trouble with code completion in MonoDevelop 3.0.4.7. At first it would only update to reflect only changes after customer restarted, but currently it isn't updating. 

Also, the directory '~/.config/MonoDevelop' does not exist on the customer's MacBook Pro machine.

Received the following:
my_username1:.config my_username$ pwd
/Users/my_username/.config
my_username1:.config my_username$ ls
gtk-2.0 inkscape menus stetic xbuild
my_username1:.config my_username$ rm -r ~/.config/MonoDevelop/CodeCompletionData
rm: /Users/my_username/.config/MonoDevelop/CodeCompletionData: No such file or directory

Attempted to re-install MonoDevelop 3.0.4.7, but did not help. The syntax highlighting is incorrect for types in the referenced MonoTouch Binding Project. 

They are running Mac OS X Version 10.7.5
Comment 1 Mikayla Hutchinson [MSFT] 2012-10-16 16:44:06 UTC
MD has not used a ~/.config directory on Mac/Windows since version 2.4. In MD 3.0, the code completion cache directory is ~/Library/Caches/MonoDevelop-3.0/DerivedData

What code completion is broken? Is it just for referenced binding projects?
Comment 2 Isaac.Eckert 2012-10-16 17:55:48 UTC
MonoTouch has a feature to bind to an Objective-C library using a MonoTouch Binding Project.  The project generates hidden *.g.cs files containing proxy objects from supplied metadata.  The result of building this project is an assembly that contains  proxy classes for accessing the associated Objective-C libraries from C#.  The assembly can be opened in object browser and nothing appears unusual.

So, none of the proxy classes are recognized by the syntax highlighter or code completion for some reason.  There is no indication that the proxy classes exist.  However, everything compiles just fine and the proxy classes call Objective-C code without any issues.

At first I thought this was a general issue since syntax highlighting has been a little slow and sometimes required a restart.  Now, I see that it is occurring exclusively for the proxy types after several restarts and installs.
Comment 3 Mike Krüger 2012-10-17 00:47:37 UTC
The good news is that we've a fix - the bad that it'll take some time to release it :/
Comment 4 Mike Krüger 2012-10-18 00:05:48 UTC
I backported the fix to the 3.0.x series.