Bug 780 - Document formatting issues with Cyrillic characters
Summary: Document formatting issues with Cyrillic characters
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 2.6
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2011-09-13 11:18 UTC by Chris Hardy [MSFT]
Modified: 2011-09-14 06:54 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Chris Hardy [MSFT] 2011-09-13 11:18:44 UTC
Document Format have strange behavior (press Ctrl E|Ctrl D)
next line (adding to dictionary)
-> elements.Add ("дата", prms);
turn to
-> elements.Add ("дата", prm s );

add new space (prm?s) always after 3th letter)

it's happen only if line contains string in Cyrillic alphabet, and on win7

And Document Format changing line endings, after formating showing "Do you want to convert the line endings?"
Comment 2 Mike Krüger 2011-09-14 06:54:59 UTC
Was a very strange problem - I had no chance to find that on mac.

The parser uses Encoding.Default to parse the text, but my text editor stream is in UTF8. On mono Encoding.Default defaults to UTF8 that's why the streams are compatible.

On windows however the Encoding.Default is a different one - that's why the streams are incompatible.

fixed.