Bug 7559 - I cant use single quote and double quote
Summary: I cant use single quote and double quote
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: unspecified
Hardware: Other Windows
: Normal normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2012-10-01 05:04 UTC by Iwan
Modified: 2013-10-29 23:52 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Iwan 2012-10-01 05:04:14 UTC
Since the last release of monodevelop i can't use double or single quotes anywhere in the developer.

Codeview / codebehind

layoutfiles etc.
Comment 1 Iwan 2012-10-01 05:14:46 UTC
the last release of mono i mean
Comment 2 Mikayla Hutchinson [MSFT] 2012-10-01 14:55:57 UTC
Are you sure that platform is you reported is correct? MonoDevelop on Windows does not run on Mono. What are the versions of Mono and MonoDevelop? What keyboard layout are you using?
Comment 3 Iwan 2012-10-02 03:08:11 UTC
Here is the info you needed i think. Sorry for the incomplete bugreport, didnt know what you needed :)

My OS is windows 7 64 bits. 
Im working with mono for android version 4.2.6. Most of the time i develop with visual studio 2010 but sometimes it crashes (when you use tablelayout for example..the designer crashes and in monodevelop it works normal) so i try to fix it with monodevelop (version 3.0.4.7). 

My keyboard layout is us international. language dutch.

After the last release of mono for android i have the single/double quote issue.

Anywhere else i can use the single/double quote.

Thanks for you help.
Comment 4 Schobers 2013-04-22 17:01:18 UTC
I'm also experiencing the same problem. I'm using Windows 7 x64, Dutch with the Dutch .NET redistributables installed. My keyboard layout is US English, US (international) and in all other applications I've tried to use it the dead keys (e.g. ' key followed by e key results in é) work perfectly. The input method in the text editor is System (Windows IME).

However when using Xamarin Studio 3.0.4 it refuses to input these characters or a (double) quote at all (no output, when used in combination with a vowel it just produces the plain vowel without the symbols above it). Changing the input method to "Simple" causes a different, but also undesired behaviour (the ' key results in ´ and the " key results in ¨).
Comment 5 Schobers 2013-04-22 17:02:43 UTC
Correction: I'm using Xamarin Studio 4.0.3 (build 13)
Comment 6 Luzanne 2013-09-03 13:30:52 UTC
I have the same problem. I can't use a " or ' in the editor. I can only add these chars to copy paste them from another place.

My keyboard layout is Netherlands - US (international).

Xamarin Studio
Version 4.1.9 (build 6)
Installation UUID: aa8fc005-2273-42e6-b741-f5a79febb6b1
Runtime:
	Microsoft .NET 4.0.30319.18047
	GTK+ 2.24.20 theme: MS-Windows
	GTK# (2.12.0.0)

Xamarin.Android
Version: 4.8.2 (Starter Edition)
Android SDK: C:\Users\User\AppData\Local\Android\android-sdk
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.3   (API level 18)
Java SDK: C:\Program Files (x86)\Java\jdk1.6.0_39
java version "1.6.0_39"
Java(TM) SE Runtime Environment (build 1.6.0_39-b04)
Java HotSpot(TM) Client VM (build 20.14-b01, mixed mode, sharing)

Build Information
Release ID: 401090006
123fc693ab9ba2690f93fcfe2cd3499335049ff4
Build date: 2013-08-06 13:13:03Z
Xamarin addins: ad4a498b75333e43547e87574c1ec8c7cae05de0

Operating System
Windows 6.1.7601.65536 (64-bit)
Comment 7 Mike Krüger 2013-10-29 23:52:09 UTC
Should be fixed with the 4.0.14 (november) release