Bug 7555 - References to projects not built in current configuration should give clearer error
Summary: References to projects not built in current configuration should give clearer...
Status: NEW
Alias: None
Product: Tools
Classification: Mono
Component: xbuild ()
Version: unspecified
Hardware: PC Linux
: --- enhancement
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-09-30 18:01 UTC by Andres G. Aragoneses
Modified: 2012-10-01 14:40 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 7555 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description Andres G. Aragoneses 2012-09-30 18:01:31 UTC
Steps to reproduce:
1. Create solution.
2. Add project TestProgram to it (console app).
3. Add project TestLib (library).
4. Add some code in TestLib.
5. Make TestProgram call the code in TestLib (TestProgram reference TestLib).
6. Disable build of TestLib in DEBUG configuration.
7. Delete manually all bin and obj folders.
8. Rebuild solution on DEBUG configration.

Current results:
TestProgram compilation fails saying if you're missing an assembly reference (TestLib not found).

MS.NET results:
TestProgram compilation fails because file TestLib/bin/Debug/TestLib.dll is not found. (Still kind of obscure message, but at least it gives a hint)

Expected results (we could be better than MS.NET here):
Fail the build of TestProgram with something like "TestProgram depends on TestLib project, which is not configured to be built in this configuration: DEBUG"  


This bug has an easy workaround if you know that the bug exists (simply fix the build configuration), so not sure if I'll have enough motivation to fix it...