Bug 7552 - Problem - Class with the same name WebService
Summary: Problem - Class with the same name WebService
Status: NEEDINFO
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Web Services ()
Version: 3.0.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-09-30 15:13 UTC by Ruda
Modified: 2017-09-05 21:04 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 7552 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEEDINFO

Description Ruda 2012-09-30 15:13:35 UTC
There is a webservice that has this structure

WebService.User
WebService.Entities.User

In the User class has a WebService method that returns a WebService.Entities.User

Except that when generating the client in monodevelop for MonoTouch, a problem occurs in classes with the same name.

In Visual Studio, when generating the WebService is named UserClient to avoid these conflicts.

Web References/WS.User/Reference.cs(25,25): Error CS0579: The attribute `System.Diagnostics.DebuggerStepThroughAttribute' cannot be applied multiple times (CS0579)
Web References/WS.User/Reference.cs(28,28): Error CS0579: The attribute `System.ComponentModel.DesignerCategoryAttribute' cannot be applied multiple times (CS0579)
Comment 1 Ruda 2012-09-30 17:16:20 UTC
Wrong.
Visual Studio generates for the User and User1 WebService object to return.
Comment 2 Ruda 2012-09-30 17:17:06 UTC
Wrong.
Visual Studio generates for the WebService User and User1 to the return object.
Comment 3 Will Smith 2017-09-05 21:04:10 UTC
Thanks so much for taking the time to submit this report! I’m unable to reproduce this issue using the latest Visual Studio 2017 for Mac Preview version 7.2. Please attach the following to help us reproduce this issue: 
-Detailed reproduction steps 
-Version information (Visual Studio → About Visual Studio menu) 
-Logs (Help → Open Log Directory, zip logs for the last 10 days) 
-Optional: project to reproduce your issue