Bug 7548 - UI becomes less responsive, quit and save results in freeze/race condition
Summary: UI becomes less responsive, quit and save results in freeze/race condition
Status: RESOLVED DUPLICATE of bug 5647
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 3.0.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2012-09-29 15:05 UTC by Yvan Rodrigues
Modified: 2012-10-24 19:21 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Just debugging code... (429.32 KB, text/plain)
2012-09-29 15:05 UTC, Yvan Rodrigues
Details
Can't toggle breakpoints, better restart. (429.32 KB, text/plain)
2012-09-29 15:06 UTC, Yvan Rodrigues
Details
This time I just chose "Quit and Save" -- UI was still being normal. (64.62 KB, text/plain)
2012-09-30 18:29 UTC, Yvan Rodrigues
Details
Opened a project, made some changes, Quit and Save (67.23 KB, text/plain)
2012-09-30 18:42 UTC, Yvan Rodrigues
Details
Couldn't set breakpoints, tried to close, had to force close (470.10 KB, text/plain)
2012-10-01 15:15 UTC, Yvan Rodrigues
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 5647

Description Yvan Rodrigues 2012-09-29 15:05:39 UTC
Created attachment 2647 [details]
Just debugging code...

MonoDevelop 3.0.4.7
MonoTouch 6.0.2

This happens to me many times a day.

- I'm working
- The UI gets a little weird e.g. breakpoints won't toggle, folders won't open/close in solution browser, but application generally sort of works.
- "oh oh", I think. MonoDevelop->Quit and close all Windows
- Freeze -- have to force quit

I'll add dumps as they occur.
Comment 1 Yvan Rodrigues 2012-09-29 15:06:56 UTC
Created attachment 2648 [details]
Can't toggle breakpoints, better restart.
Comment 2 Yvan Rodrigues 2012-09-30 18:29:37 UTC
Created attachment 2655 [details]
This time I just chose "Quit and Save" -- UI was still being normal.
Comment 3 Yvan Rodrigues 2012-09-30 18:42:48 UTC
Created attachment 2657 [details]
Opened a project, made some changes, Quit and Save
Comment 4 Yvan Rodrigues 2012-10-01 15:15:23 UTC
Created attachment 2665 [details]
Couldn't set breakpoints, tried to close, had to force close
Comment 5 Jeffrey Stedfast 2012-10-24 19:21:27 UTC

*** This bug has been marked as a duplicate of bug 5647 ***