Bug 7531 - #endregion not indenting when copy / paste into IDE
Summary: #endregion not indenting when copy / paste into IDE
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: C# Binding ()
Version: 3.0.x
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2012-09-28 11:23 UTC by SamUrai
Modified: 2012-10-01 02:07 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description SamUrai 2012-09-28 11:23:10 UTC
When I copy a block of code from one .cs file to another, if it contains one or more region blocks, the #endregion tags do not indent. #region does indeed indent after the paste, but it's corresponding #endregion is not indented. Example:

Code that is copied:

          #region MyFunction
          public void MyFunction()
          {
               // do something
          }
          #endregion

Code after it is pasted into a different c# file:

          #region MyFunction
          public void MyFunction()
          {
               // do something
          }
#endregion

And if copying multiple blocks of region code, it will do this for each #endregion in the clipboard.

I do not remember this being an issue in previous versions of MonoDevelop.
Comment 1 Mike Krüger 2012-10-01 02:07:55 UTC
fixed