Bug 7527 - Regression in Regex from 2.10.9 to 2.10.10
Summary: Regression in Regex from 2.10.9 to 2.10.10
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System ()
Version: 2.10.x
Hardware: Macintosh Mac OS
: --- critical
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-09-28 09:40 UTC by Chris Hardy [MSFT]
Modified: 2013-01-09 15:32 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Chris Hardy [MSFT] 2012-09-28 09:40:58 UTC
Running the following code with Mono 2.10.9 in a console application works as expected.

https://gist.github.com/8d310103fcbcdd7663c7

Putting the same code into a Mono 2.10.10 console app causes the console app to hang.
Comment 1 Rodrigo Kumpera 2013-01-09 15:32:51 UTC
Fixed,will be part of the next release.