Bug 7460 - iOS5 SDK MKMapView on iOS6 Region bug
Summary: iOS5 SDK MKMapView on iOS6 Region bug
Status: RESOLVED ANSWERED
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: 6.0.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Future Cycle (TBD)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-09-25 22:41 UTC by Wilden
Modified: 2016-02-17 19:17 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
code and pictures (2.02 MB, application/zip)
2012-09-25 22:41 UTC, Wilden
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Wilden 2012-09-25 22:41:14 UTC
Created attachment 2617 [details]
code and pictures

We now encounter an issue which we are not sure how and why that occurs. 
In the attached files, you can find that I try to extend a mapview to a component which I can allow other view controller to use it. The issue is, i originally put setRegion method in 'public override void LayoutSubviews ()' method. It works fine on ios5 sdk publishing to ios5 iphone and ios6 sdk publishing to ios6 iphone. However, if I use ios5 sdk publishing to ios6 iphone, the setRegion method doesn't work. It might be either I got something wrong with setRegion or LayOutSubviews method. The work around way is I put "this.Region = _region;" in my mapView constructor to force writing value into Region. Please let me know if I did something wrong or it's ios5 sdk publishing to ios6 iphone thing.
Comment 1 Sebastien Pouliot 2012-09-26 09:04:31 UTC
I can duplicate this, surprising.
Comment 3 PJ 2013-11-19 16:45:05 UTC
This bug was targeted for a past milestone, moving to the next non-hotfix active milestone.
Comment 4 GouriKumari 2016-01-12 22:25:40 UTC
Moving this bug to "far future" milestone.
Comment 5 Rolf Bjarne Kvinge [MSFT] 2016-02-17 19:17:55 UTC
We don't support the iOS 5.0 SDK anymore (the latest version of Xamarin.iOS requires the iOS 9.0 SDK), so this from what I can tell this is not an issue anymore (and the test project works fine when built with the iOS 9.0 SDK).