Bug 7267 - Changing iOS device to iPad in "iPhone Application" options yields Universal (minor)
Summary: Changing iOS device to iPad in "iPhone Application" options yields Universal ...
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: 3.0.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2012-09-18 12:19 UTC by Yvan Rodrigues
Modified: 2012-10-15 15:38 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Yvan Rodrigues 2012-09-18 12:19:35 UTC
This is a very insignificant bug.
On my system it is 100% reproducible.

1. Open an iOS project in MonoDevelop.
2. Go into project -> Options (I do this by right-clicking the project and choosing Options)
3. Go to Build -> iPhone Application
4. Change Devices to iPhone/iPod if it isn't already.
5. Change Devices to iPad.
6. NOTE: Universal is selected, not iPad.

MonoDevelop 3.0.4.6
MonoTouch 5.4.1 Release ID 30004006
OS X 10.8.1
Comment 1 Yvan Rodrigues 2012-09-30 13:55:22 UTC
In case it was a fluke, just confirming that this is present in MonoDevelop 3.0.4.7, MonoTouch 6.0.2.
Comment 2 Jeffrey Stedfast 2012-10-11 14:23:12 UTC
fixed in git, but probably won't make it into 3.0.5
Comment 3 Jeffrey Stedfast 2012-10-15 15:38:26 UTC
(might just make it into 3.0.5 after all)