Bug 7129 - IDE crashes on addition of an empty resource file
Summary: IDE crashes on addition of an empty resource file
Status: RESOLVED NORESPONSE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 3.0.x
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2012-09-13 07:09 UTC by Ajit
Modified: 2013-12-05 18:34 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Ajit 2012-09-13 07:09:54 UTC
Whenever a new empty resource file is added to an existing solution/new solution , the MonoDevelop I.D.E. crashes, and approximately 76 new instances of MonoDevelop get recursively created(everytime) if we try close the IDE manually. 
System hangs pathetically. 
"System.Resources.MissingManifestResourceException: Could not find any resources appropriate for the specified culture or the neutral culture." is very very common.
Addition and Deletion of resources not getting properly logged in .csproj file too. 
Checked it in versions 3.0.3.5 and 3.0.4.6 both, same error persists.
Please fix it soon!
Comment 1 Alan McGovern 2012-09-17 08:15:07 UTC
The issue seems to be that you have associated MonoDevelop as the default application to open '.resources' files, yet MonoDevelop cannot actually open these files directly. MonoDevelop just defers to the OS and asks the OS to open the files using the default viewer. As the OS thinks MonoDevelop is the default viewer, it ends up endlessly recursing as you've described.

'.resources' files are binary files normally generated by the 'resgen' tool using '.resx' files as the input. They are then compiled into the final assembly as embedded resources. You probably want to add resx files to your project, not .resources files. 

How can you trigger the '"System.Resources.MissingManifestResourceException: Could not find any
resources appropriate for the specified culture or the neutral culture." issue. Can you provide a solution or testcase demonstrating the problem?
Comment 2 PJ 2013-11-19 17:04:35 UTC
This bug has been in the NEEDINFO state with no changes for the last 90 days. Can we put this back into the NEW or CONFIRMED state, or are we still awaiting response?

If there is no change in the status of this bug over the next two weeks, this bug will be marked as NORESPONSE.
Comment 3 PJ 2013-12-05 18:34:42 UTC
This bug has not been changed from the NEEDINFO state since my previous comment, marking as RESOLVED NORESPONSE.

Please feel free to REOPEN this bug at any time if you are still experiencing the issue. Please add the requested information and set the bug back to the NEW (or CONFIRMED) state.