Bug 7112 - Installing standalone MFA msi without MFA pre-requisites results in a non user-friendly error after starting VS2012
Summary: Installing standalone MFA msi without MFA pre-requisites results in a non use...
Status: VERIFIED NOT_REPRODUCIBLE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: unspecified
Hardware: Macintosh Windows
: --- enhancement
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-09-12 16:11 UTC by Peter Collins
Modified: 2016-08-03 15:23 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED NOT_REPRODUCIBLE

Description Peter Collins 2012-09-12 16:11:21 UTC
After installing the stand alone MFA MSI on a fresh VM without any other MFA pre-requisites (Java/Android SDKs, .net, etc) causes visual studio to throw a System.ArgumentNullException on start.

Adding an error message informing the user that they are missing certain pre-requisites would be a useful enhancement, although I would assume this issue won't be encountered frequently.


Expected Behavior:
The user is informed of the lack of installed pre-requisites (.net framework, java and android SDKs, etc)

Actual Behavior:
Series of system error messages that don't explicitly point out the lack of pre-requisites.
(System.ArgumentNullException: Value cannot be null.

Environment Details:
MFA 4.2.4 and 4.2.5
Win8x32 and Win8x64
VS2012
Comment 1 Peter Collins 2013-05-14 19:27:35 UTC
Going to go ahead and close this bug out, the universal installer we ship checks for and installs all required prerequisites.